CryptoFly.us | CRYPTOCURRENCY BITCOIN SHIRTS CLOTHING APPAREL HATS

CRYPTO NEWS

Ethereum price hits $3,800, boosting bulls' control in Friday's ETH options expiry

ETH price recaptured the $3,800 level and derivatives data signals bulls are well-positioned for Friday’s $385 million options expiry.

Compatibility problem: Truffle version is 0.5.16 but Solidity file requires 0.8.3

My smart contract (SC) file has the following line: pragma solidity ^0.8.3; When I am compiling it with truffle, I am getting following error: Error: Truffle is currently using solc 0.5.16, but one or more of your contracts specify "pragma solidity ^0.8.3". Please update your truffle config or pragma statement(s). (See https://trufflesuite.com/docs/truffle/reference/configuration#compiler-configuration for information on::Listen

My smart contract (SC) file has the following line:

pragma solidity ^0.8.3; 

When I am compiling it with truffle, I am getting following error:

Error: Truffle is currently using solc 0.5.16, but one or more of your contracts specify "pragma solidity ^0.8.3". Please update your truffle config or pragma statement(s). (See https://trufflesuite.com/docs/truffle/reference/configuration#compiler-configuration for information on configuring Truffle to use a specific solc compiler version.)  Compilation failed. See above. Truffle v5.1.67 (core: 5.1.67) Node v10.23.3 

The contents of my configuration file are:

module.exports = {   // See <http://truffleframework.com/docs/advanced/configuration>   // for more about customizing your Truffle configuration!   networks: {     development: {       host: "127.0.0.1",       port: 7545,       network_id: "*" // Match any network id     },     develop: {       port: 8545     }   } }; 

Somebody please guide me how to solve this compatibility problem.

Zulfi.

Ethereum price hits $3,800, boosting bulls' control in Friday's ETH options expiry

Shopping cart
There are no products in the cart!
Continue shopping
0